Çarşamba , Kasım 14 2018
En Taze Makaleler
Ana Sayfa / Makaleler / İleri Excel Formülleri

İleri Excel Formülleri

İster bilişimci, ister muhasebeci ol.handan-erdag-50-ileri-excel

Ne olursan ol.

Yeter ki Excel kullanmayı doğru bil…

İş hayatında kimimizin küçük, kimimizin de büyük bir zamanını kaplayan yüzyılın değil, milenyumun icadı Excel programını ne kadar doğru bir şekilde kullanıyorsunuz? Ya da Excel’li gerçekten de kullanabiliyor musunuz?

excel

Bu makalemde hepimizin sağından, solundan bir köşesinden kullandığı Excel programı ile ilgili, günlük kullanabileceğiniz birbirinden pratik formüllerin yazılışlarını ve kullanımlarını, örnekler ile açıklamaya çalışacağım.

Veri Aktarımı 

Excel’de Sayfalar Arası Veri Aktarımı

Kullanımı: =SayfaAdı!Hücre Adı

Örnek: =yada!B10

Farklı Excel Kitaplarında Veri Aktarımı

Kullanımı: =[KitapAdı.xls]SayfaAdı!Hücre Adı

Örnek: =[Vergiler.xls]yada!B10

Hücre Sabitleme

Sabit Sütun

Kullanımı: =$SütunAdı$SatırNo+SütunSatırNo

Örnek: =$A$2+B2

Sabit İki Sütun

=$Sütün Adı$satır no * $Sütün Adı$satır no

=$F$4*$B$6

Hücreleri dilediğimiz şekilde sabitleyerek hesaplama yapabiliriz.

Hücre sabitlemeyi yazmak zor gelirse “=” hücre adı + F4 ile hücreyi sabitleyebilirsiniz.

Eğer Formülü

Bu formül yardımıyla bir test koşulunun doğru ya da yanlış olmasına göre farklı işlemler yapılabilir.

Formülün Kullanımı :  =Eğer(koşulKoşul doğru iseKoşul doğru değilse)

Örneğin:  =Eğer (A10 > 10; “10’dan büyük”, “10’dan küçük”)

Açıklaması: Eğer A10  hücresindeki değer 10’dan büyükse “10’dan büyük”, değilse “10’dan küçük” yaz.

Eğer-ve Formülü:

Birden fazla şartın belirtilmesi durumunda kullanılır. Eğer fonksiyonu ile birlikte kullanılır.

Formülün Kullanımı :  =Eğer(Ve(şart;şart…); “doğruysa_değer” ; “yanlışsa_değer”)

Örnek:  =EĞER(VE(C2>=50;D2=”Devamlı”);“Tatili Hakettin”;”Sana Tatil Falan Yok, Git Ötede”

Açıklaması: Eğer C1 de ki not 50’nin üstün de; D’ de ki devam durumu da Devamlı ise  “Tatili Hakettin” yazsın. Her iki koşulun da yerine getirilmesi durumunda “Tatili Hakettin” yazar.

Eğer-Yada Formülü:

Eğer-Yada fonksiyonunda şartlardan bir tanesinin doğru olması işlemi yaptırmak için yeterlidir.

Formülün Kullanımı :  =Eğer(Yada(durum;durum…); “doğruysa_değer” ; “yanlışsa_değer”)

Örnek: Tablomuzun C sütunun da notlar, D sütununda da devam durumu var.  Buna göre Eğer ya da formülünü şu şekilde kullandık:

=EĞER(YADA(C1>=50;D1=”Devamlı”);”Tatili Hakettin”;”Sana Tatil Falan Yok, Git Ötede Oyna”)

Açıklaması: Eğer C1 de ki not 50’nin üstün de yada D’ de ki devam durumu da “Devamlı” ise  “Tatili Hakettin” yazsın. Bu formül de koşullardan biri dahi yerine getirilirse “Tatili Hakettin” yazar.

Eğersay Formülü:

Belirtilen aralıktaki değerleri belirtilen ölçütü sağlayan hücrelerin sayılmasını sağlar.

Formülün Kullanımı: =Eğersay(koşulAralık; Koşul)

Örnek: =Eğersay(A1:A10;“10”

Açıklaması: A1 ile A10 arasında 10 olan değerlerin sayısı

Örnek: =Eğersay(B4:B14;“Kaldı”)

Açıklaması: B4 ile B14 arasında olan değerlerde Kaldı olanların sayısını verir.

Etopla Formülü:

Belirtilen aralıktaki hücrelerden belirtilen şartı sağlaması durumunda belirtilen diğer hücrelerin toplamını verir.

Formülün Kullanımı:  =Etopla(Sorgulanacak Hücre Aralığı;“Şart”;“Toplanacak Hücre Aralığı)

Örnek: =Etopla(A1:A10;“10”;B1:B10)

Açıklaması: A1 ile A10 arasında bulunan sayılardan içerisinde 10 sayısı varsa o hücreye denk gelen B sütunundaki hücre değerini topla.

Örnek: =ETOPLA(B1:B19;”<=0″;B1:B19)

Açıklaması: B1 ile B19 arasında ki sıfıra eşit ve sıfırdan küçük yani negatif sayılar varsa onları toplar.

Örnek: =ETOPLA(A1:A10;”>0″;B1:B10)

Açıklaması: A1 ile A19 arasında ki sıfırdan büyük yani pozitif sayılar varsa o hücreye denk gelen B sütunundaki hücre değerini toplar.

Excel ile ilgili yazacağım formüller şimdilik bunlar. Ancak üç vakte kadar ileri excel formülleri ile ilgili yeni makaleleri de sitede bulacaksınız.

Devam Edecek…

Sevgili Okuyucu, bak bu makalede ilgini çekebilir.

Ayrılık Tiyatro Oyunu

2 comments

  1. Baya bir kişinin işine yarayacak bilgiler. Bunları bilmeyen bir çok insan var çünkü hala 🙂

    • Kesinlikle… Herkesin bilgi düzeyi aynı değil. O yüzden de 7’den 70’e hedef alarak yazmak lazım 🙂

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir